Error loading plugin file; The plugin probably needs some DLLs missing on your system

Jul 2, 2009 at 9:34 PM

All plugin files from the zip are in a tcmd subdir.

When trying to register the plugin, using tcmd 7.50ß6 on vistax64u, I get the following error:

 

Error loading plugin file!

The plugin probably needs some DLLs missing on your system.

 

 

I added the wfx manually to wincmd.ini, went to \\Network\, selected SkyDriveExplorer which rightclicking shows a connect window which does nothing and goes away.

 

A doubleclick on \SkyDriveExplorer gives another error window:

Error, could not load the plugin!

<Path to>SkyDriveExplorer.wfx

Coordinator
Jul 3, 2009 at 11:40 AM

Hi Bam,

I just finished of deploying a Windows 7 x86 and x64  test environments and found the same as you: some DLLs are missing.

Then I deployed Visual Studio on both environments and everything started to work fine.

I realized that the tool/library I use to be able to write TC plugin in .Net, requires additional redistributable package (Microsoft Visual C++ 2008) to be deployed.

Could you try it to download the package from Microsoft's site, deploy it and try to run the plugin again and post the result here?

Here is the URL to the package: http://www.microsoft.com/downloads/details.aspx?familyid=9B2DA534-3E03-4391-8A4D-074B9F2BC1BF&displaylang=en

 

Regards,

Gabor

Jul 3, 2009 at 9:09 PM
Edited Jul 3, 2009 at 9:30 PM

heya,

 

The Microsoft Visual C++ 2008 Redistributable Packages (SP1 also), x86 and x64 are installed.

I just reinstalled those 4 packages (useless) and tried to add the wfx... same errors (obviously).

 

If the error stated what was missing...

Missing other DLL's apparently.

 

Best regards,

 

Bam

Jul 6, 2009 at 9:32 PM

Note:

when using Total Commander's Lister on the wfx, the DLL Dependancy Tab shows a Missing DLL red icon for for files 'MSVCR90.dll' and 'msvcm90.dll'.

 

Which are both in various flavours in the \winsxs directory, as mentioned in the post above.

Coordinator
Jul 6, 2009 at 11:35 PM

Hi Bam,

Sorry for late answering. I'm quite busy these days ...

This is what I could figure out as well. The plugin depends on those DLLs, which can be nicely found in \winsxs ... but the plugin still cannot be loaded ... I don;t know why!

What I could figure out is that if Visual Studio 2008 is deployed (including Visual C++) even on x86 and x64, the plugin works fine?!?

So far I could not figure out what V2008 deploys which are essential for the plugin ...

 

Gabor

Coordinator
Jul 10, 2009 at 10:37 PM

Hi Bam,

Good news! I've found those missing DLLs! I'll make some additional tests and then update the current release package asap.

Best regards,

Gabor

Coordinator
Jul 13, 2009 at 9:55 PM

New release package is available, which includes those missing DLLs!

Best regards,

Gabor

Aug 20, 2012 at 11:07 PM

I just deployed this on Windows 8 and Total Commander 8.01, and I'm getting the same error here. Any ideas?